Tag Archives: router

FIX: Asus RT-N56U doesn’t see the second USB hard disk

The Asus RT-N56U has been out for a little while now; it’s been proven to be quite a popular home consumer router as it comes with many features for a decent price (dual-band including N-band wireless and media streaming, for example).

As with most hardware products, there’s an occasional need to upgrade the firmware, to address bugs, security issues and/or introduce new features. Around 2013 ASUS introduced a completely new firmware for the router which removed features from the router – chiefly the media server. Instead these features had to be installed on an attached USB hard disk. Not only that but the latest version of the media server software ASUS supply (minidlna v1.0.33) has a bug which fails to index all content.

Media Server Fix 1 – Downgrade to 1.0.0.22

Simply follow these steps – version 1.0.0.33 has the issue mentioned. You’re basically doing a manual merge of file to over-write the media server. If you need a copy of the files, you can download from here.

Media Server Fix 2 – Second Hard Drive Doesn’t Appear for DLNA devices (like PS3)

If you’re like me, your media server install (and other router related files) is on the same drive as media you are streaming. But when you connect a second drive, you may find that you can see the drive using the file share (samba) or FTP but DLNA devices (like the PS3) don’t seem to see it. This appears to be because the second drive takes a few seconds to mount (or register – the router uses unix and this is how it handles hard disks) and so when the media server goes to look at what’s available, doesn’t see it.

Solution 1 – Web Interface

You can try to either disable and then re-enable the media server via the web interface:

ASUS Wireless Router RT N56U   USB application

or telnet into the router and force a restart with re-index:

  • Start your telnet session
    • For Windows see this link
    • For OSX, go to Utilities > Terminal > type “telnet <your router IP>”
  • Login using your router username and password you setup
  • If you want to confirm you have multiple disks mouted, type

cat /proc/mounts  – you will see

/dev/sda1 /tmp/mnt/Media ufsd rw,nodev,nls=utf8,uid=0,gid=0,fmask=0,dmask=0,force 0 0

(Media refers to the name i gave this drive)

/dev/sdb1 /tmp/mnt/Shared ufsd rw,nodev,nls=utf8,uid=0,gid=0,fmask=0,dmask=0,force 0 0

(Shared refers to the name i gave this drive)

the key part is sda1 refers to the first hard disk; sdb1 refers to the second; note they’re both mounted via /tmp/mnt

  • Type minidlna -f /opt/etc/minidlna.conf -R which will force the DLNA server to re-index.
    For info, the “-f /opt” refers to the config file for miniDLNA and “-R” is the command to force a re-index
  • Now go to your routers miniDLNA status page – this should be http://<router-ip> :8200 – e.g. http://192.168.1.1:8200 – this will give you a count of the re-index process. Depending on the number of files, this could take a while!

And you’re done! Hopefully this helped take the mystery out of resolving this issue.

IMPORTANT NOTE: There is a known security issue with the router that has been resolved with the latest firmware – if you are using the ASUS cloud service that lets you access your files over the internet you need to update ASAP. See the ASUS files site for info.

Advertisements